AIR SDK 33.1.1.98 does not fix the mp4 video playback bug

unfortunately this SDK release does not fix the mp4 video playback bug https://github.com/Gamua/Adobe-Runtime-Support/issues/250

There doesn’t seem to be a workaround - The only version video can play correctly is SDK 32.0.0.89 will not be compatible when I try to submit to the app stores.

This is kind of frustrating to be left on the sideline with a bug that doesn’t seem to be getting any attention for the past 3 months from Harman. What is the process for raising a red flag over there ?

1 Like

wait a minute

on issues

those concern only the Windows platform

so why are you talking about “app stores” ? is it the same problem n mobile?

if not, then you already got your workaround

  • setup multiple AIR SDK versions
  • use AIR SDK 32.0.0.89 to publish on Windows
  • use AIR SDK 33.1.1.98 to publish on mobile and macOS

off course I would always advice

  • do an automated build
  • run it all on the command-line
  • it is configurable and repeatable

Now about the bug itself I have few questions

  • are you sure you are following the constraint/limits that support AIR for video playback?
    eg. Video Encoding Cookbook and Profile Guidelines for the Adobe® Flash Platform (PDF)
    • have you tried ffmpeg on the command-line to be 300% sure you generate a correct mp4 ?
    • what tools do you use to generate/format/encode/etc. the video ?
    • have you tried other encoding ?
      if for example you use AAC for sound, maybe try MP3
      eg. try lower bitrate, lower width x height size, etc.
      and if so, does those other formats create issues too?
  • if you use stage video, do you detect it or try to use it right away?
    eg. you need to wait for an event to use stagevideo
  • are you testing with a paid or free license for the Harman AIR SDK ?
1 Like

Thanks for all these tips - I’m going to wade through them this week and see if I can fix my vids. I will respond with more detail as I solve this.

i’ve been looking at this - #211 [iOS][tvOS] Video object doesn’t playback MP4 H.264 videos

I am MacOS developing only for ios and android. I use Adobe Media Encoder and Animate2020. Purchased licence from Harman

I think I’m trying to play it right away -
nsMain.play(VFILE_NAME);
nsMain.addEventListener(NetStatusEvent.NET_STATUS, statusHandler);

One encouraging sign - metaData.duration; gives me the correct duration time of the video when nsMain.play
and I can see the video frozen on first frame.

It just seems like the listener is bouncing things all over the place and the vid freezes on the first frame.

1 Like

Hello Zwetan,

I didn’t find new version of AIR SDK_33.1.1.98

https://airsdk.harman.com/download

The latest version of AIR SDK available is 33.1.1.86

Hi Kumar,

wait a little while, sometimes when they update their website they kind of revert 1 version earlier

this version does exist, for ex

you can see @ajwfrost answering

@davecates are you able to check with the release we made at the weekend, 33.1.1.98, which contains updated code for both Windows and MacOS to try to resolve these issues.
Thanks

btw the AIR SDK 33.1.1.98 is back online

Thank You For Your Information.

I did some tests here to confirm the problem.

Adobe Animate 2019
AIR 32 and others 33for Android

// Simple code to load MP4 video:
import fl.video.*;
var test:String = "./U2 - Vertigo.mp4";
myPlayer.source = String(test);

PS .: The video is not public, access is only via the link provided.

I’ve found a solution. it works with the latest 33.1.1.98 - and it uses the good 'ol timey FLV ! I’m not kidding. You have to get rid of any AAC sound. Like zwetan suggested - you have to use .mp3 sound. The only program that does that easily is AvidMux for me

AvidMux 2.7.4 - download here - http://avidemux.sourceforge.net/

Import your mp4 with any sound. Export it using these setting

Video output = FLV1(flash)
Audio Output = MP3 (lame)
OutputFormat = FLV Muxer

The only bummer is the file size of my small 30 second videos is twice the size now. Everything else is working fine (a slight hiccup on iPads as the video starts to roll) - even the meta duration works.

1 Like

.mp4 can use use AAC or MP3

MP4 can be either seen as only the video format, eg. H.264 or HEVC
or as a container, eg. MPEG-4

MPEG-4 Part 14 or MP4 is a digital multimedia container format most commonly used to store video and audio, but it can also be used to store other data such as subtitles and still images. Like most modern container formats, it allows streaming over the Internet. The only official filename extension for MPEG-4 Part 14 files is .mp4 . MPEG-4 Part 14 (formally ISO/IEC 14496-14:2003 ) is a standard specified as a part of MPEG-4.

with FFmpeg, you would take an MP4 containing video and audio (AAC) and could convert only the audio to MP3

$ ffmpeg -i original.mp4 -acodec mp3 -vcodec copy output.mp4

  • -i original.mp4 take the container “original.mp4” as input
  • -acodec mp3 encode the audio stream with the MP3 codec
  • -vcodec copy copy the video stream “as is” (eg. do not re-encode it)
  • output.mp4 save the output file into “output.mp4”

some ref about FFmpeg

in short -acodec mp3 will use the default settings to encode with MP3
and there are many other parameters to control the bitrate, CBR/VBR, etc.

1 Like

The NetStream feature is also not working with Android since Adobe Air 33.1
If Android is the Receiver of a live video stream the sound and video transmission is broken. Tried a lot of workarounds, different rendering modes, but no chance. All emails I sent to Harman stay without any response and this problem is still not fixed.
Maybe someone here has an idea or solution. The last working version of the Air SDK is 33.0.2.338

have you posted about it on https://github.com/Gamua/Adobe-Runtime-Support/issues ?

Can’t get ffmpeg to work for me. Following your instructions

$ ffmpeg -i original.mp4 -acodec mp3 -vcodec copy output.mp4

I did create the mp4 with mp3 - Video plays fine but the audio somehow is muted or not playable on my mac or in the animate2020. Something is wrong either with my mp3 compressor, or playback.

ffmpeg is not the easiest for me to use. Thanks anyways for the help

with what you report it seems you don’t have the mp3 codec installed
and/or you don’t have installed other codecs to translate from like AAC etc.

double check how you installed ffmpeg, either homebrew or macports
you will have to check if the mp3 codec/library is installed and/or supported

for ex
$ ffmpeg -formats | grep "mp3"
$ ffmpeg -codecs | grep "mp3"

what you’re describing is in general explained like that

  1. If you build FFmpeg without the --enable-libmp3lame flag and try to encode to Flash video, the audio stream will be silently discarded. Only by encoding to another format that does not require MP3 will you discover that this is not the expected behavior. In this case just follow the instructions in this article to install LAME, if necessary, and recompile FFmpeg with LAME support.

thanks . a think the article you are referring to is http://stephenjungels.com/jungels.net/articles/ffmpeg-howto.html

I assumed the LAME was installed automatically with homebrew - referring to this

I was able to see the mp3 codec in my ffmpeg install. But when I run ffmpeg it still gives me blank audio in Animate2020 and my QuickTime player . I can hear the audio if I play the video on VLC. So I know the ffmpeg is successful with the mp3 audio - I just can’t get it to work with Animate2020.

Also - I installed all the features at https://github.com/varenc/homebrew-ffmpeg

posted at github, adobe tracker and the adobe support community

1 Like

Confirming that this serious issue is still present in AIR 33-1-1-98 on Mac OSx.
We’ve been streaming MP4 video from Vimeo Pro for 5+ years without any problems. With AIR33 the video stalls on the first frame. Also confirming the last SDK to work without this issue is AIR 32-89.
Same problem applies to AIR 33.1.1.86 on both Mac and Win.