Mac Catalina AIR SDK 33 with FreSwift not working

Hello
I use FreSwift in my air project…

MacOS: Catalina
Air SDK : 33
Adobe Animate : 2020

The error is :

Termination Description: DYLD, dependent dylib '@rpath/FreSwift.framework/FreSwift' not found for '/private/var/containers/Bundle/Application/7EF51169-44BE-4354-904C-ED33DA645537/xxxAPP155.app/xxxAPP155', tried but didn't find: '/private/var/containers/Bundle/Application/7EF51169-44BE-4354-904C-ED33DA645537/xxxAPP155.app/Frameworks/FreSwift.framework/FreSwift' '@rpath/FreSwift.framework/FreSwift' '/System/Library/Frameworks/FreSwift.framework/FreSwift'

Highlighted by Thread: 0

I tried to put FreSwift.framework in APP_ROOT/Frameworks/FreSwift.framework, and I build the IPA without error.
when I install the IPA into iPhone, the app can not be installed, it displays as gray icon.

When I build the ANE, I verify that there is FreSwift.framework inside my app.ane, but when I build the IPA, I don’t see the FreSwift.framework inside the app.ipa.

Here is platform.xml:

<?xml version="1.0" encoding="utf-8"?>
<platform xmlns="http://ns.adobe.com/air/extension/32.0">
    <sdkVersion>12.1</sdkVersion>
    <linkerOptions>
       <option>-ios_version_min 9.0</option>
        <option>-w</option>
        <option>-ObjC</option>
        <option>-rpath @executable_path/Frameworks</option>
        <!-- <option>-lstdc++</option> -->

    </linkerOptions>
    
    <packagedDependencies>
        <packagedDependency>Frameworks/FreSwift.framework</packagedDependency>
        <packagedDependency>Frameworks/KizANE_FW.framework</packagedDependency>
    </packagedDependencies>
    
</platform>

Anyone has ideas ?

Thanks

The error is clear. The FreSwift framework is not found inside the Frameworks folder.

In Animate (Included files section) package the ios_dependencies/device folder - that should then package the complete Frameworks folder

N.B. The FreSwift.framework inside the ANE is there for linking purposes. You also need to explicitly package it using your IDE.

Unzip your .ipa file and confirm the structure is like this (including libSwift__.dylib files and your KizANE_FW.framework):

Thank you Tuarua,

I did try to put Frameworks , and I have verified the 2 frameworks inside the IPA file. when I install the IPA file, it’s. waiting…installing…then the Icon becomes gray…

I can not launch the app

That folder structure looks ok.

I can not launch the app

What does the crash-log say?

Before building your own app did you build and run the starter project that comes with the repo.

Hi tuarua, I have tried to build starter project, but I can’t make it worked. I did 3 tests

  1. Build swc with IntelliJ IDEA with namespace 33 in extension_ios.xml and platform.xml.

<platform xmlns="http://ns.adobe.com/air/extension/33.0">

Then I build ane using build_ios.sh, it worked.

Then I build the IPA with this ane, the error is

I didn’t find a place in Animate 2020 to change the namespace, I did try to modify the namespace to 33 in the xml configuration file, but every time I publish, Animate change the namespace back to 32, and show this error again.

  1. Build swc with IntelliJ IDEA with namespace 32 in extension_ios.xml and platform.xml.

no problem to build the swc, but when I build the ane with build_ios.sh, the error is

Setting path to current directory to: 
Making directories. 
Copying SWC into place. 
Extracting files form SWC. 
Archive: ./HelloWorldANE.swc  
inflating: ./library.swf 
Copying library.swf into place. 
Copying native libraries into place.
 Copying Swift dylibs into place for device. 
Building ANE. 
Invalid swc file. The extension NameSpace requires the SWF verison to be 43 or lower 
Finished.
  1. Build swc using acompc command line with namespace 32

"$AIR_SDK"/bin/acompc - **source** -path "$pathtome/../../native_extension/src" -include-classes com.xxx.XXXANE -swf-version=13 -optimize -output "$pathtome/../../native_extension/bin/XXXANE.swc"

and then build ane using build_ios.sh , it works

then build IPA using Animate, it works

but when I install the IPA to iPhone, when the installation finished , the app Icon is gray, I click on the app icon, it says: app can not be installed.

As it’s not installed, there is not a crash-log ( Or I don’t know where to find an installation error log)

Do you have Animate 2020 and air sdk 33 ? could you help me get out of this …please ?

I don’t use/own Animate. I am using AIR 33.0.2.288 / 315 and IntelliJ on Mac Catalina. I have no such installation problems with the sample or other FreSwift based ANEs.

1.2 The sample ANE uses namespace 19 for both the platform and extension xml with -swf-version=30 - you probably should have left as 19

Open the Console app and filter on the name/id of the app.
That might show the installation problem.

Apart from that there is not a lot of feedback I can provide. “app can not be installed” is not a useful error. It could be anything and may not be related to the ANE.

You may be better served by uploading a minimal project which reproduces the problem to GitHub.

Hi tuarua,

I have found the issue was my XXX_ANE.FW was not signed, then I rebuild the framework with develop certificate, it’s installed and it works.

But when a build the project in production mode for distribusion to apple store, I get the error email from Apple Review :

Dear Developer,
We identified one or more issues with a recent delivery for your app, “XXXX” 4.4.0 (4.4.0). Please correct the following issues, then upload again.
ITMS-90433: Invalid Swift Support - The file libswiftCore.dylib doesn’t have the correct code signature. Make sure you’re using the correct signature, rebuild your app using the current public (GM) version of Xcode, and resubmit it. Don’t just modify the code signature of libswiftCore.dylib.
Best regards,
The App Store Team

And I tried to install the IPA, the error in iPhone console is :

-[IXSDataPromise cancelForReason:client:]: <IXSPlaceholder(0x102a050a0) Name:App Placeholder: XXX (com.xxx.app) Creator:AirTraffic UUID:5C3CBA60-E48C-4BCA-A448-C33E3CC9F718> : canceled by client 17 for reason Error Domain=IXUserPresentableErrorDomain Code=1 “This app could not be installed at this time.” UserInfo={NSUnderlyingError=0x102a54280 {Error Domain=MIInstallerErrorDomain Code=13 “Failed to verify code signature of /private/var/installd/Library/Caches/com.apple.mobile.installd.staging/temp.lXwwsu/extracted/Payload/XXX.app : 0xe8008015 (A valid provisioning profile for this executable was not found.)” UserInfo={LibMISErrorNumber=-402620395, LegacyErrorString=ApplicationVerificationFailed, SourceFileLine=183, FunctionName=+[MICodeSigningVerifier _validateSignatureAndCopyInfoForURL:withOptions:error:], NSLocalizedDescription=Failed to verify code signature of /private/var/installd/Library/Caches/com.apple.mobile.installd.staging/temp.lXwwsu/extracted/Payload/XXXX.app : 0xe8008015 (A valid provisioning profile for this executable was not found.)"

I see someone says that :

When sending the app to Apple they require you IPA to contain 2 copies of each Swift library.

1 - One contained inside of Payload/NAME.app/Frameworks/libswift*.dylib
2 - Another one contained inside of SwiftSupport/libswift*.dylib

The first one has to be signed using your signing key.
The second one can’t be signed by you! It must be the exact same version as the first one, but exactly as it came with Xcode.

The 1 one, I copy from ios_dependences/device
The 2 one, I think it’s Adobe Animate extracts from Xcode ?

My Xcode version is 11.1,

What do you think how to fix it ?

Thank you

My Xcode version is 11.1

10.1 or 11.1 ?

What version of FreSwift are you using? If you are using 3.1.0 and trying to use Xcode 11 then you have ignored the readme.

That’s definitely the wrong thing to do. You shouldn’t sign the framework. adt does that.

I’m afraid you seem to be diverting away from what is outlined in the project(s) provided and then blaming your problems on the FreSwift framework (you’re saying doesn’t work and how do I fix rather than what am I doing wrong).

If you need further assistance please contact me and I can provide paid support.

1 Like

Hi tuarua

I am sorry for troubling you, and I am really asking that what am doing wrong.

I am not saying the issue came from FreSwift, it could be Apple certificates, Adobe Animate, Air SDK, Mac Catalina or something I did wrong. I just want to know if someone had the same issue and can give me some advices.

Thank you so much for your replies.

I am using Xcode 11.1, FreSwift 4.0.0 , Adobe Animate 2020, Air_sdk 33.