netStreaming video - not playing in sim or device

the latest AIR 33.1.1.63 is giving me problems with my netStreamed video. Not able to “play” the video after it seems to load properly.
I’m able to see the duration of the loaded video
metaData.duration;

function myLoader(): void {
nsMain.play(VFILE_NAME);
nsMain.addEventListener(NetStatusEvent.NET_STATUS, statusHandler);

}
function statusHandler(event: NetStatusEvent): void {
switch (event.info.code) {
case “NetStream.Play.Stop”:
trace(“all done vid - nextFrame”);
nextFrame();
//trace(“all done vid - goto vid_pause”);
//gotoAndStop(“vid_pause”);
break;
}
}

Android simulator and iOS sim not able to play video. made using AnimateCC.

This all seemed to be playing nicely - when I was usingthe previous Harman SDK. Did something change with 33.1.1.63?

Seems it AIR 33 issue (still not fixed) with Windows and macOS platforms:


And related issues:






1 Like

Video playback has been a mess since Adobe started implementing the new internal pipeline. I’m stuck with version 32.0.0.89 in x86 which seems do be the last one with the old pipeline. I’ve been facing all sorts of issues on Windows with every release since then:

  • double to triple memory and CPU usage;
  • memory leaks caused by streams not being properly released in x64;
  • videos randomly refusing to play or scrub.

It’s been widely documented but doesn’t seem to be a priority at Harman yet.

2 Likes

I would say what other encoding have been tried?

If you look at what coding profile Flash/AIR support for H.264 codec
it says level 1 to 4.2

AIR_H264

so my guess is the video where you encounter problems are encoded with parameters outside what is supported and yeah it could cause issues in a lot of way

see

see all the encoding variant listed at the end, for ex

too much bitrate, too higher this or that, etc. yep it will prevent the video to play smoothly

1 Like

thanks for all these - I’m trying to compress using Adobe Media Encoder - no luck so far.

The new release AIR_SDK_33.1.1.86 does not fix the problem either.