Putting ipa made with AIR 32 onto ios iPad 13

Hello! I am trying to get an update into Apple before the June 30 deadline to upgrade to iOS 13. I made my app with AIR 32 that worked in September 2019, but now when I try to install the app via adt on my iPad directly, it fails.

My last resort is creating a distributable version of the app and loading into the app store, testing with TestFlight. However, there has to be way to get my ipa done with development provisioning and certificate to test on my iPad. I tried using iMazing to install the development app but it gave me an error (kAMD Missing Package Path Error).

I am reluctant to go to the Harman AIR 33 SDK because I would need to add storyboards and the like, but does anyone have a suggestion as to how to get my development ipa onto an iPad for testing otherwise?

Thanks!

-jonathan

are you on Windows or macOS? and so which version of the OS?

if you are under macOS, have you XCode installed? if so which version?

Same, if you are under macOS, have you tried to install with xcrun on the command-line ?

thanks for quick reply. I am on Windows 10. I do have a Mac as well, with XCode version 11.3.1. I have not tried installing from the command line, I don’t know how to use xcrun, can you point me to where I can look on how to do this?

Thanks!

I just opened Xcode and tried to install it but I got a generic error “Unable to install”. I tried installing my older (iOS 12) ipa that was uploaded to the App Store fine in Oct 2019. That also got the error “Unable to install”.

sure

How to upload IPA file to App Store from Mac OS X Catalina

Try xcrun altool command line:

xcrun altool --upload-app --type ios --file <Path-to-ipa> --username <Username> --password <One-time-pass>

Remember to use the one time pass from https://appleid.apple.com/account/manage .

No double quote for the content, just replace the < Path-to-ipa >,< Username > and < One-time-pass >!

I’m using Xcode11.1.

Click here to the source answer!


and that source answer is
How to upload IPA now that Application Loader is no longer included in Xcode 11

From Console you can do:

xcrun altool --upload-app --type ios --file <Path-to-ipa> --username <Username> --password <One-time-pass>

Remember to use the one time pass from https://appleid.apple.com/account/manage and to omit the double quotes on PATH, USERNAME, and PASSWORD

Apple transporter

There is also a new app that Apple released that allows developers to send files to App Store Connect

https://apps.apple.com/us/app/transporter/id1450874784?mt=12


Alternatively you can also try libimobiledevice
on their web site http://www.libimobiledevice.org/
and their github issues https://github.com/libimobiledevice/libimobiledevice/issues

Sources and Dependencies:

simple usage is described here
Installing an .ipa on your iOS device from command line in OSX or Linux

eg. ideviceinstaller -i <Path_to_your_ipa>

Thanks for the info, I used xcrun to upload to the app store before (back in Sept 2019), I am looking for a way to test the new version I just made on my device first. I can’t seem to find how to use xcrun to try to get it onto my device.

-jonathan

well …

maybe start with the basic of what have you already tried?, does your device is found/detected?

I’m not in front of your screen nor in your head

without giving details of your setup/config not much I can do to help

I appreciate you responding, I understand there are too many variables to solve this specifically without detail. I tried loading the ipa into the iOS simulator and it failed, and I even tried loading the app-store-approved ipa into the simulator, and that failed as well. My only hope at this point is packaging the ipa for app store distribution then test it in Test Flight. Regardless, I expect to upgrade the AIR SDK to the current for iOS 13 (and add storyboards, recompile ANE’s, etc.), I was just hoping to get a last update in before the June 30 deadline – since I had gone through the exact same process in Sept 2019. I think the fatal flaw was updating my iPads to iOS 13.

OK so there, you got an IPA that is approved by the app store but it does not load into the emulator

what is your macOS version ?
how does it run? (VM?, real hardware? etc.)

what is your XCode version?
what are the settings of the emulator?
maybe you setup some customization and forgot about them?

have you double checked your certificates validity?
see https://developer.apple.com/support/certificates/

  • iOS Distribution Certificate (App Store)
    If your Apple Developer Program membership is valid, your existing apps on the App Store will not be affected. However, you will no longer be able to upload new apps or updates signed with the expired or revoked certificate to the App Store.
  • iOS Distribution Certificate (in-house, internal use apps)
    Users will no longer be able to run apps that have been signed with this certificate. You must distribute a new version of your app that is signed with a new certificate.

try that
$ security find-identity -v -p codesigning
what is listed?

compare with that
$ security find-identity -p codesigning
see the bottom part saying “valid identities found”
what does it say? everything valid or not?

or check in XCode, in “Preferences / Accounts”, refresh if you need to

also check your https://developer.apple.com/account/ and https://developer.apple.com/account/#/membership/ABC3DEF456

I will check out the security you suggested, I did check my certificates and it looks like my development provisioning profile disappeared, I wonder if that expired. I actually made a fair amount of progress thanks to your suggestion and I had written to Harman (Andrew Frost) advised going the libimobileuser and ideviceinstaller route – big thanks to Andrew for his prompt and personal reply, and of course to you, Zwetan, you rock.

I had a h**l of a time getting libimobileuser installed on my Mac trying to follow the vanilla instructions.

In case others are stuck as well, here is what happened.Basically I would try to install libimobileuser and it would complain about not having the correct version of usbmuxd, and when I tried to download and install the correct version of that directly from github, it complained I did not have the correct version of libplist. I tried getting the current version of libplist from github, I changed my PKG_CONFIG_PATH, still no go.

I’ll skip to the chase, this post eventually solved it – the key thing seemed to be installing usbmuxd through brew (i.e., brew install --HEAD libplist), and also installing libplist through brew (i.e., brew install --HEAD libplist), before using brew to install libimobileuser.

brew uninstall --ignore-dependencies libimobiledevice
brew uninstall --ignore-dependencies ideviceinstaller
brew uninstall --ignore-dependencies usbmuxd
sudo rm /var/db/lockdown/*
brew install --HEAD usbmuxd
brew unlink usbmuxd
brew link usbmuxd
brew install --HEAD libplist
brew unlink libplist
brew link libplist
brew install --HEAD libimobiledevice
brew install --HEAD ideviceinstaller

Once I did this, I was able to load my ipa onto my ipad with ideviceinstaller -i . That’s when I got the errors about the executable (possible provisioning issue), but I feel I am making progress to the light at the end of the tunnel (even if it turns out to be an oncoming train, which it often does seem working in the Apple environment).

1 Like

yeah it can be a bit rough around the edge

and thinking again to the original problem

could it not be simple as you need AIR 33 to target iOS 13 ?

not completely sure on that one, not at all in the mobile dev recently

but anyway yeah check step by step: device connection, certificates, etc.

at one moment you gotta find what is the blocker

Hello Jon,
I am not sure if this can help, rather than ADT I enjoy using this tools to install software on my iOS devices: https://www.itools4.com/
The free version allows to manage installed apps.
cheers
PS
Following this thread. Lots of useful info thank you.

Hi PippoApps, thanks for the tip about itools4. I had tried (but didn’t say) that I used iMazing (which is great, BTW), and that didn’t work. Crazy thing is that I couldn’t even get the approved earlier version of my app, submitted in Sept, 2019, to load on my iPad. Go figure!

It’s clear I need to go to AIR 33 but I assumed if I target iOS 13 I would have to do the storyboard and icon changes. While I very much wanted to find out what was going wrong and fix it, I realized I was running out of time and I didn’t want to risk not having the update in before the June 30th deadline, to avoid the worst-case scenario of something crazy in me not being able to fulfill the new requirements of iOS 13. I fully expect to get the app running in iOS 13 with AIR 33, but the shortest path to get an update into the App Store was just push the production version to Apple and wait until I could test the app with TestFlight.

I hate giving up like that but other pressures/obligations forced my hand. I expect to have better luck (and more time!) now that at least I have my app update in. BTW on a positive note, my app was approved in 1 day so that was impressive for Apple, my review period has typically been 3-5 days.

1 Like